Команда network в BGP на Cisco

Давайте рассмотрим Вот такую конфигурацию:

R1#
interface Loopback0
ip address 10.10.10.157 255.255.255.252

interface GigabitEthernet0/0
ip address 10.10.10.154 255.255.255.252

interface GigabitEthernet0/1.10
encapsulation dot1Q 10 native
ip address 10.10.20.129 255.255.255.192

interface GigabitEthernet0/1.20
encapsulation dot1Q 20
ip address 10.10.20.193 255.255.255.192

router bgp 100
bgp log-neighbor-changes
neighbor 10.10.10.153 remote-as 200
neighbor 10.10.10.153 ebgp-multihop 10
!
address-family ipv4
neighbor 10.10.10.153 activate
neighbor 10.10.10.153 send-community
neighbor 10.10.10.153 soft-reconfiguration inbound
no auto-summary
no synchronization
network 10.10.10.152 mask 255.255.255.248
network 10.10.20.128 mask 255.255.255.128
exit-address-family

Если прописать сеть вот таким образом:

network 10.10.10.152 mask 255.255.255.248

то попасть на лупбек-интерфейс 10.10.10.157 снаружи не получится.

Но если сеть разбить вот так:

network 10.10.10.152 mask 255.255.255.252
network 10.10.10.157 mask 255.255.255.255

То всё получится!

Как работает команда network в BGP на маршрутизаторах Cisco? Когда, в каких случаях можно использовать агрегированные адреса?

Всё дело в том, что команда network не создаёт маршруты! Она всего лишь анонсирует в BGP то, что уже имеется в таблице. А так как маршрута 10.10.10.152/29 в таблице нет, то и в BGP он не рассылается. Чтобы этот пример заработал,  необходимо прописать статический маршрут. Вот так:

ip route 10.10.10.152 255.255.255.248 Null0 200

Преимущества использования в маршруте интерфейса Null:

  • Предотвратить флапы (если есть реальный интерфейс в сети, который может регулярно мигать);
  • Добавить сеть в маршрутную таблицу, при том, что она там никаким другим способом не появится.

Добавить комментарий

Ваш адрес email не будет опубликован.

*

code